wlbk.net
当前位置:首页 >> 请老师做一个通达信自动画线公式 要求:每个波段的... >>

请老师做一个通达信自动画线公式 要求:每个波段的...

画线函数是不能放在选股公式里的应该放在指标公式里,Ctrl+f 公式编辑器

KX:DRAWKLINE(H,O,L,C);ZG:IF(HHV(H,60),CONST(HHV(H,60)),DRAWNULL),COLORWHITE;ZD:IF(LLV(L,60),CONST(LLV(L,60)),DRAWNULL),COLORGREEN;

你所指的单K线是什么? 恕我愚笨,仅个人理解,你所说的:“单K线的涨幅在0.5%~3%,画线值为此K线涨幅的中间值”,就是只要达到“单K线的涨幅在0.5%~3%”这个条件,就在该涨幅均值处画线; 但画线一般取阶段性高或低点(或者其它特定条件,比如历史高点或低点等),不能随意画(那样屏幕上会被画线占据满而失去画线的意义); 另外,你给的“0.5%~3%”是一个不确定的值,系统是无法判断究竟是取该区间的哪个值,你再琢磨一下,把你的意思完整地告诉我,最好有图.

自动画线可以,但前提是你需要定义,划线的条件,以什么条件开始以什么条件结束.什么时候画线什么时候不画线.例如下面图中两种划线方法都是根据macd指标的条件在主图做划线公式,前两张图是,最近一次macd产生背离情况后,会在主图与副图上画线,其他时间不画钱.另一张是,把上一次金叉到死叉过程中的最高价划线做压力,把上一次死叉到金叉过程中最低价线画线做支撑. 除了以上两种还可以根据高低点连线,但高低点连线大部分都是存在未来函数效果的.这取决于,你定义高低点的条件.

ma(c,5);drawicon(c/ref(c,1)>=1.095,ma(c,5),1);drawicon(h/ref(c,1)>=1.095,ma(c,5),1);以上公式表示只要当天的股价触摸了涨停或是收盘涨停就在5日均线上画一个向上的箭头,第一个画图是收盘涨停.

EVERY(L<MA(C,20) AND H>MA(C,20) AND MA(C,20)>REF(MA(C,20),1),3); 股票公式专家团为你解答,希望能帮到你,祝投资顺利.

VAR1:=(2*CLOSE+HIGH+LOW)/4;VAR2:=EMA(EMA(EMA(VAR1,4),4),4);J:=(VAR2-REF(VAR2,1))/REF(VAR2,1)*100;D:=MA(J,3);K:=MA(J,1);XG:CROSS(K,D);

lc:=ref(close,1);rsi1:sma(max(close-lc,0),9,1)/sma(abs(close-lc),9,1)*100;wr1:100*(hhv(high,9)-close)/(hhv(high,9)-llv(low,9));这是副图指标lc:=ref(close,1);rsi1:=sma(max(close-lc,0),9,1)/sma(abs(close-lc),9,1)*100;

你发的图很模糊,看看下面的指标是否符合你的要求:做空能量线: SMA((HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100,2,1),COLORGREEN,LINETHICK3;做多能量线: SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,5,1)-8,COLORRED,LINETHICK3;20,POINTDOT,COLORF00FF0;50,POINTDOT,COLORGREEN;80,POINTDOT,COLORWHITE;

LC:=REF(CLOSE,1); RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100; 低吸:=CROSS(RSI,11); VARF:=(2*CLOSE+HIGH+LOW)/4; VA4:=LLV(LOW,34); VA5:=HHV(HIGH,34); VA6:=EMA((VARF-VA4)/(VA5-VA4)*100,6);

网站首页 | 网站地图
All rights reserved Powered by www.wlbk.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com